404 Errors During Lease Signing

Incident Report for Tenant Service Status

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 09:01 PST

Investigating

We are currently experiencing an issue where some users may encounter a 404 error when attempting to sign a lease.

Our teams are actively investigating and working toward a resolution. We’ll share an update as soon as more information is available.

If you have any questions or need assistance, please contact Tenant Support at support@tenantinc.com.
Thank you for your patience.
Posted Jan 14, 2026 - 08:35 PST
This incident affected: Mariposa and Hummingbird.