Communication Service Disruption

Incident Report for Tenant Service Status

Resolved

The issue affecting communication functionality has been resolved, and services are operating normally.

We appreciate your patience while our team worked to resolve the issue.
Posted Aug 31, 2026 - 15:45 PDT

Investigating

We are currently investigating an issue affecting communication functionality within Hummingbird. Customers may experience interruptions or delays with certain incoming communications.

Our team is actively working to restore full service. We will provide additional updates as more information becomes available.

We apologize for the inconvenience and appreciate your patience.
Posted Aug 31, 2026 - 09:56 PDT
This incident affected: Hummingbird.