Tenant Warehouse services are restored and are fully operational at this time. Tonight's jobs will run as scheduled subsequent to which your dashboards should reflect the latest metrics as per the regular cadence
Posted Oct 20, 2025 - 15:08 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:15 PDT
Identified
Last night, the Tenant platform experienced a service disruption caused by a widespread Amazon Web Services (AWS) outage. The outage began at 11:30 PM PT and persisted until approximately 4:00 AM PT. During this time, customers may have experienced an inability to access the Tenant platform or delays in key operations.
As of this morning (4:30 AM PT), all core services across Hummingbird and Mariposa are fully operational. The nightly business process jobs (Billing, Delinquency, Autopay, etc.) are all caught up and current as of the present time. The Tenant Warehouse service remains impacted. We are actively collaborating with AWS Enterprise Support to restore full functionality and expect resolution in the next few hours.